Author Topic: M-unit - config button/kill switch problems  (Read 166 times)

0 Members and 1 Guest are viewing this topic.

Offline w-nolan

  • Full Member
  • *
  • Posts: 8
M-unit - config button/kill switch problems
« on: June 12, 2019, 04:24:14 pm »
Cb550 Cafe - m-unit v2.  M-switch mini 5 button plus a config button.  Cali has already reviewed and blessed my wiring diagram.  OEM Keyes switch.  Just got the bike back together in May was running great
Was tinkering around chasing a charging problem and so somehow I ended up shutting down  the m-unit.  I rechecked the connections - power and ground are solid.
The only thing I did different was I Used the config button as a kill when testing the charging ststem components.  At this point:  when I turn the key on three light race around the M-unit counter clockwise.  The rear brake light blinks as well.  Starter does not activate.  I have tried to do a factory reset based on what the guys from Revival suggested .  Hold config button for 10s in the set up menu.  This did nothing.  I have also disconnected both mainpower & ground and reconnected hoping it would reset but still no change.  next I plan to completely disconnect and test and reconnect but I’m skeptical.


Offline calj737

  • Moderator
  • Really Old Timer ...
  • *****
  • Posts: 19,635
  • I refuse...
Re: M-unit - config button/kill switch problems
« Reply #1 on: June 13, 2019, 04:46:06 am »
I have never been a fan or had luck with leaving a CONFIG button wired in. You only need it during SETUP anyway, so remove it from the loom.

Remove the MAIN power, reset the functions, and start over with your programming. Should only take 5 minutes. If that doesn’t resolve the issue, I’d suspect a damaged unit due to a prior charging problem? I had to send 2 units back last year for similar reasons where the owner MUST have swapped polarity while charging his bike.  ;)
'74 550 Build http://forums.sohc4.net/index.php?topic=126401.0
'73 500 Build http://forums.sohc4.net/index.php?topic=132935.0

*** Currently experiencing life at 60 WTFs per hour ***
I always thought getting old would take longer

Offline w-nolan

  • Full Member
  • *
  • Posts: 8
Re: M-unit - config button/kill switch problems
« Reply #2 on: June 13, 2019, 09:44:19 am »
Great thanks - I'll give it a try.

Your the man!

 

;