Author Topic: Wiring Schematic: M-Unit blue with Motoscope tiny, M-switch mini, Boyer Bransden  (Read 401 times)

0 Members and 1 Guest are viewing this topic.

Offline Frosty

  • Full Member
  • *
  • Posts: 34
Hi there!

I made a wiring schematic for the M-Unit blue on my CB750 K7, with the connector plugs already in it. I wonder if it is ok the way it is. The main differences to stock are:

- M-Unit blue
- Motoscope Tiny Speedo
- M-Switch mini
- Rick's Lithium Reg/Rec 14_100
- Universal Starter Solenoid from Revival Cycles
- Boyer Bransden electronic ignition Kit 289
- no indicator lights

I ordered a set of Deutsch waterproof connectors to put it all together. The grey marked connectors are in the headlight, the speedo for the most part as well.

A few things that I'm unsure of:

1. I guess I don't need the 1 amp fuse from ignition out on M-Unit to the Speedo, or do I?
2. Regarding the ingnition lock, I found not much info on the necessity of putting in a 1 amp fuse there? Can I take the original ignition lock and just connect the red and black cable like in my schematic?

Revival Cycles has neither the first nor the the second fuse in their scematic here: https://technicalarticles.revivalcycles.com/hc/en-us/articles/360016476671-Motoscope-Tiny-With-m-Unit-Wiring-Diagram

3. I'll use AWG 18 wire for everything apart from the ingoing connections on the m-Unit (with the exception of LOCK) and the wires from Reg/Rec and stator harness (i use the cables provided). And obviously the main battery cables, frame ground, etc. will be much thicker. I wonder if the cables from Ignition out on the m-unit to the ignition should be AWG 14 instead of 18

If someone can shed some light on any errors, I'd be much obliged.

The Boyer Bransden Kit came with the bike when I bought it, but my current wiring loom is a total mess, so I attached the schematics of that kit, and the ones from the speedo and solenoid too.

Since most parts are difficult to get in Norway where I live, I ordered most stuff ahead, and will make the final order from vintage connections once I get the ok from you guys if my assesment is correct.

Thanks all for your help!

Offline theDQG

  • Full Member
  • *
  • Posts: 96
Yes you do need that 1 amp fuse going to speedo and ignition switch because you are powering those directly from the battery, not from the M-unit, itself.

Those are a pain in the ass to crimp, especially the super tiny 24 AWG coming from the motoscope tiny- a trick you can use is to strip a good length of 24 awg and fold it back on itself three times so that you can crimp it with a 20 or 22 awg connector. 

I use 20 AWG and you can use the smaller 18-22 AWG deutsch connectors. I love the deutsch connectors- they are the best.
« Last Edit: May 09, 2020, 09:16:16 am by theDQG »
'83 xv920
'76 xs650
cb750 k4 (2)
'81 R100RS

DQG = The Dumb Question Guy. I ask dumb questions all the time. Bike over ego.